Skip to main content Skip to docs navigation Bootstrap 4 (安定版) はこちらです

ダウンロード

コンパイルされた CSS、JavaScript、ソースコード、npm や RubyGems といった好きなパッケージマネージャで Bootstrap をインストールできます。

目次

コンパイルされた CSS と JS

すぐに使えるコンパイルされた Bootstrap v5.0.0-alpha1 のコードをダウンロードできます。以下が含まれます。

ここにはドキュメントやソースファイル、オプションである Popper.js のような JavaScript は含まれません。

ダウンロード

ソースファイル

Sass、JavaScript そしてドキュメントを含むソース・ファイルをダウンロードして、あなたの環境でコンパイルできます。そのためには以下のツールが必要です。

Bootstrap とそのドキュメントを開発するためにビルドツールが含まれていますが、使わない可能性が高いでしょう。

ソースをダウンロード

サンプル

サンプルページから様々なサンプルをダウンロードして試すことができます。

サンプルのダウンロード

BootstrapCDN

ダウンロードせずに BootstrapCDN から配信されるコンパイルされた CSS、JS を使うこともできます。

<link rel="stylesheet" href="https://stackpath.bootstrapcdn.com/bootstrap/5.0.0-alpha1/css/bootstrap.min.css" integrity="sha384-r4NyP46KrjDleawBgD5tp8Y7UzmLA05oM1iAEQ17CSuDqnUK2+k9luXQOfXJCJ4I" crossorigin="anonymous">
<script src="https://stackpath.bootstrapcdn.com/bootstrap/5.0.0-alpha1/js/bootstrap.min.js" integrity="sha384-oesi62hOLfzrys4LxRF63OJCXdXDipiYWBnvTl9Y9/TRlw5xlKIEHpNyvvDShgf/" crossorigin="anonymous"></script>

もし、コンパイルされた JavaScript を使う場合は、Popper.js をそれよりも前に参照しましょう。

<script src="https://cdn.jsdelivr.net/npm/popper.js@1.16.0/dist/umd/popper.min.js" integrity="sha384-Q6E9RHvbIyZFJoft+2mJbHaEWldlvI9IOYy5n3zV9zzTtmI3UksdQRVvoxMfooAo" crossorigin="anonymous"></script>

パッケージマネージャ

ほとんどのパッケージマネージャで Bootstrap の source files を Pull することができます。パッケージマネージャに関係なく Bootstrap は Sass コンパイラーと Autoprefixer を必要とします。

npm

npm パッケージ を使って、Bootstrap をインストールします。

npm install bootstrap@next

const bootstrap = require('bootstrap')import bootstrap from 'bootstrap' は全ての Bootstrap のプラグインを bootstrap オブジェクトにロードします。 bootstrap モジュールは全ての Bootstrap のプラグインをエキスポートしています。 そのため、パッケージの最上位のディレクトリで /js/dist/*.js ファイルをロードすることで Bootstrap のプラグインを個別にロードすることができます。

Bootstrap の package.json は次のメタデータを含んでいます。

yarn

the yarn package を用いて Bootstrap をインストールできます。

yarn add bootstrap

RubyGems

Ruby アプリ Bundler (推奨) と RubyGemsGemfile からインストールできます。

gem 'bootstrap', '~> 5.0.0-alpha1'

Bundler を使ってない場合は、以下のコマンドで gem をインストールできます。

gem install bootstrap -v 5.0.0-alpha1

gem の README を見る

Composer

Composer を使って Bootstrap の Sass と JavaScript をインストールできます。

composer require twbs/bootstrap:5.0.0-alpha1

NuGet

.NET で開発しているのであれば NuGet を使って Bootstrap の CSSSass、JavaScript をインストールできます。

Install-Package bootstrap
Install-Package bootstrap.sass